ElectricMotorcycleForum.com

  • August 20, 2017, 06:31:13 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

Electric Motorcycle Forum is live!

Pages: [1]

Author Topic: First real problem after 11k miles  (Read 468 times)

nnelson65

  • Newbie
  • *
  • Posts: 12
    • View Profile
First real problem after 11k miles
« on: February 16, 2017, 11:52:47 PM »

digital readout on the dash stopped working.
Logged

nnelson65

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: First real problem after 11k miles
« Reply #1 on: February 16, 2017, 11:54:13 PM »

 I tried power cycling it a couple of times. The backlight came back on and the readout was faintly visible after 10 miles or so. It totally went out again and then came back on, looking normal except for the clock, which looked like this...
Logged

nnelson65

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: First real problem after 11k miles
« Reply #2 on: February 16, 2017, 11:54:55 PM »

Now when I power the bike on, the speedo reads "EEE" for a second at the end of its startup cycle.  I suspect water ingress to the dash or the connector to the dash. It's been raining like crazy here lately...
Logged

nnelson65

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: First real problem after 11k miles
« Reply #3 on: February 16, 2017, 11:58:24 PM »

Also, every once in a while the time will flicker back on (correct time). I'd guess water in the dash itself.
Logged

Fred

  • Full Member
  • ***
  • Posts: 225
    • View Profile
Re: First real problem after 11k miles
« Reply #4 on: February 17, 2017, 01:11:55 AM »

Looks like a dodgy connection between the LCD and the rest of the dash. You could be right about water ingress, especially if it had one of those elastomeric connectors that goes directly to the glass.
Logged

KrazyEd

  • Sr. Member
  • ****
  • Posts: 344
    • View Profile
Re: First real problem after 11k miles
« Reply #5 on: February 17, 2017, 01:08:36 PM »

Not sure of the age of your bike, but, if still under warranty, I would think that it should be covered.
Beyond that, I am a Valet and see similar issues on some older cars that I park, most notably BMW
and Mercedes. Usually seems to be bad boards ( my theory ). On these, it must be expensive
to fix as I do not recall ever seeing one working after it has broken. If not covered, I would imagine it
would be a less expensive fix than on the cars. I have seen posts regarding the instrument cluster ( dash? )
pointing to the manufacturer with the ability to buy for other uses. Possibly on here. This was a few
years age and for earlier models, but, might be worth looking into.
Logged

Richard230

  • Hero Member
  • *****
  • Posts: 4656
    • View Profile
Re: First real problem after 11k miles
« Reply #6 on: February 17, 2017, 09:37:07 PM »

Not sure of the age of your bike, but, if still under warranty, I would think that it should be covered.
Beyond that, I am a Valet and see similar issues on some older cars that I park, most notably BMW
and Mercedes. Usually seems to be bad boards ( my theory ). On these, it must be expensive
to fix as I do not recall ever seeing one working after it has broken. If not covered, I would imagine it
would be a less expensive fix than on the cars. I have seen posts regarding the instrument cluster ( dash? )
pointing to the manufacturer with the ability to buy for other uses. Possibly on here. This was a few
years age and for earlier models, but, might be worth looking into.

BMW has a reputation for manufacturing motorcycle instrument panels that leak water after a few years when exposed to heavy rain.  Their solution is to put a drain hole in the bottom of the panel and let the water drain out.   ::)
Logged
Richard's motorcycle collection:  2014 14.2 kWh Zero S, 2016 BMW R1200RS, 2011 Royal Enfield Bullet 500 Classic, 2009 BMW F650GS, 2005 Triumph T-100 Bonneville, 2002 Yamaha FZ1 (FZS1000N) and a 1978 Honda Kick 'N Go Senior.

NEW2elec

  • Hero Member
  • *****
  • Posts: 509
    • View Profile
Re: First real problem after 11k miles
« Reply #7 on: February 17, 2017, 11:25:07 PM »

There is a FX for sale for parts on here you could pick up his dash.  I assume its all the same dash.
Logged
Pages: [1]