ElectricMotorcycleForum.com

  • February 21, 2018, 07:19:19 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

Electric Motorcycle Forum is live!

Pages: [1] 2 3

Author Topic: FIXED: 2015 SR - "open contactor" errors  (Read 2970 times)

CrashCash

  • Sr. Member
  • ****
  • Posts: 319
  • Denizen of Doom since '88
    • View Profile
FIXED: 2015 SR - "open contactor" errors
« on: February 27, 2015, 04:12:52 AM »

OK, 2 weeks ago I installed a power tank in my SR. The instructions were excellent, the hardest part was getting the data cable connector under the frame rail.

After I put it all together, I got the "BMS startup error - reset with button" and I found here on the forum that there are 2 buttons you need to hold down for 10 seconds. After I did that, no problem and I rode around fine for a week.

Sunday, I got the startup error again, so I turned the bike off and did the double button reset again. This time, when I switched it on, I get error 25/49 flashing (contactor open) and the blink-blink blink that means "contactor error"

The power tank LED activity is fine, but the main battery does nothing. No contactor click or LEDs. I think I do hear faint clicking from the controller under the seat. This is pretty consistent. The estimated range is 20-something miles, so I think it only sees the power tank. If I charge it, I hear the contactor in the power tank click, but nothing from the main battery.

I unplugged the power tank and reinstalled the loopback jack on the data connector. No joy.

I assume the silence from my dealership means they're waiting on Zero. These are folks that have had trouble putting on a tire the right way round, so I expect it'll be a bit of rough sailing. I'm being nice and not calling every day at the moment.

Wheeeeee!
« Last Edit: May 23, 2015, 02:07:14 AM by CrashCash »
Logged
'07 FJR-1300 & '15 Zero SR

ultrarnr

  • Sr. Member
  • ****
  • Posts: 395
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #1 on: February 27, 2015, 04:32:55 AM »

CrashCash,

Hopefully your dealer and my dealer don't have the same point of contact at Zero. (I live in  NC) The "contactor open" seems to be like a general fault code and it can be hard to figure out what the actual problem is. The problems you are having with your Power Tank are different than mine but mine took 6 weeks to solve and that was only after Zero sent a rep out to work on the bike. Your dealer will probably have to hook up your bike to their computer so as to send Zero the detailed log data. While this does help sometimes the problem may not show up in the logs. Mine didn't. Have you connected a smart phone to your SR? With the details on the Zero app it would be really obvious if your bike is seeing the main battery. Good luck. I know what you are going through.
Logged

Richard230

  • Hero Member
  • *****
  • Posts: 5095
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #2 on: February 27, 2015, 04:50:32 AM »

I have mentioned this before, but when my power tank was installed, the computer wouldn't connect with the new module.  First the problem was a bad power tank and then (when things still wouldn't work right) the Zero tech located a connector that had a single bent pin.  Once the pin was straightened out and the connector reattached, my bike has run perfectly ever since.  So I would carefully check all of the wiring connectors that you came in contact with when you installed the power tank to see if one of the pins was bent when the connecters were plugged into each other.
Logged
Richard's motorcycle collection:  2018 16.6 kWh Zero S, 2016 BMW R1200RS, 2011 Royal Enfield Bullet 500 Classic, 2009 BMW F650GS, 2005 Triumph T-100 Bonneville, 2002 Yamaha FZ1 (FZS1000N) and a 1978 Honda Kick 'N Go Senior.

kensiko

  • Sr. Member
  • ****
  • Posts: 351
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #3 on: February 27, 2015, 10:28:14 PM »

BMS possibly broke on the main battery after connecting the PT?
Data Cable have been damaged?

That's my list of possible causes for now.
Logged
Zero S 11.4 2013
Tesla S60 2014 CPO base
Gone -> Nissan Leaf 2014 SV rented (transfer)
Gone -> Prius 2010 bought at 180000 km.

Doug S

  • Hero Member
  • *****
  • Posts: 1148
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #4 on: February 28, 2015, 01:20:14 AM »

OK, 2 weeks ago I installed a power tank in my SR.

Obviously I'm not up to speed....how is it that YOU installed your power tank? Last I heard, that was an "installed by dealers only" option. How difficult was it to do and how much cheaper was it to do it yourself? Could I also do it on a 2014 or is it only possible on the 2015?

I'm an EE so if it's possible to do at home, I should be able to do it. I'm still not entirely sure it's worth the money for me, but if I can save some bucks doing it myself, it might just be.
Logged
There's no better alarm clock than sunlight on asphalt.

Burton

  • Hero Member
  • *****
  • Posts: 973
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #5 on: February 28, 2015, 03:24:52 AM »

Take the seal off the front of the battery case where the BMS is and there are two buttons to reset the BMS ;)

Not sure if it is the same with the 2014+ though.
Logged
All content I have created here http://bit.ly/1NX4KP9

Burton

  • Hero Member
  • *****
  • Posts: 973
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #6 on: February 28, 2015, 06:17:21 AM »

Do you have a ODBII to usb connector? Could pull down the BMS information.
Logged
All content I have created here http://bit.ly/1NX4KP9

kensiko

  • Sr. Member
  • ****
  • Posts: 351
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #7 on: March 19, 2015, 01:58:29 AM »

Good to know it's not a bad manipulation.
Logged
Zero S 11.4 2013
Tesla S60 2014 CPO base
Gone -> Nissan Leaf 2014 SV rented (transfer)
Gone -> Prius 2010 bought at 180000 km.

kensiko

  • Sr. Member
  • ****
  • Posts: 351
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #8 on: March 19, 2015, 08:22:45 PM »

Yes we need DoctorBass input here. If it's cheap, we can try to replace it ourselves.
Logged
Zero S 11.4 2013
Tesla S60 2014 CPO base
Gone -> Nissan Leaf 2014 SV rented (transfer)
Gone -> Prius 2010 bought at 180000 km.

Justin Andrews

  • Hero Member
  • *****
  • Posts: 1002
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #9 on: March 19, 2015, 09:21:34 PM »

The dealer is replacing it under warranty. I'm just hoping it's not the usual 2 month delivery time.

Zero are improving, my motor was sent out within a week.
Logged
Zero 2015 SR (+PT);
Yamaha Diversion 900

m0t0-ryder

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #10 on: March 19, 2015, 10:16:49 PM »

It is not difficult to replace the BMS card... "if" the tech has done it before.
It's also pretty easy and straight forward to upload the newer firmware.

I would suggest calling your dealer once a week for a status update.
Keep the fire lit under them so (hopefully) they do the same to Zero.
If it drags on call Zero Service for a status update.
Logged

BrianTRice

  • Unofficial Zero Manual Editor
  • Hero Member
  • *****
  • Posts: 2378
  • Nerdy Adventurer
    • View Profile
    • Personal site
Re: 2015 SR - "open contactor" errors
« Reply #11 on: March 20, 2015, 03:14:04 AM »

I would suggest calling your dealer once a week for a status update.
Keep the fire lit under them so (hopefully) they do the same to Zero.
If it drags on call Zero Service for a status update.
Ha. My boss has told me to do the same thing, since he knows I don't like dealing with people and I'd let it slide. I have been driving by since I can't hear over the phone, plus I found out in person the service manager will actually show me what's going on.

And no, they lost their "Zero tech" so he's got another "guy who's good with computers" working on it. Oh boy. I just have lots of warm fuzzies hearing that.

Your experience seems colored by your manner of interaction. I will not claim that your dealer sounds competent [you are our only witness here], but it does appear that you have issues getting the best out of people.

Logged
Zero: 2016 DSR, 2013 DS
Also: 2012 Suzuki DL-650 V-Strom Adv

Justin Andrews

  • Hero Member
  • *****
  • Posts: 1002
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #12 on: March 20, 2015, 06:40:21 PM »

Yup. The quicker those useless layabouts fix that American-made toy piece of shit, the quicker we don't have to deal with each other again.

And just like that, the last bit of sympathy I had for you just evaporated.
Logged
Zero 2015 SR (+PT);
Yamaha Diversion 900

Burton

  • Hero Member
  • *****
  • Posts: 973
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #13 on: March 20, 2015, 09:04:48 PM »

This morning it was snowing, and raining ... so I took some time to add some tape under the bike between the size six controller heat sink plate not covered by my heat sink and the bottom of the tail. Duck tape of course, since it can fix everything.

I did this to make sure the water coming from the tire didn't end up on top the controller and inside the 35pin connector.

It worked for half my trip. Where as without it I would have lasted less than a mile on the road before getting the red / green light blink pattern.

I will have to make a cover for the top of that connector now. But I should also engineer a easy way to remove and replace the seat to make taking it off easier as well.
Logged
All content I have created here http://bit.ly/1NX4KP9

Justin Andrews

  • Hero Member
  • *****
  • Posts: 1002
    • View Profile
Re: 2015 SR - "open contactor" errors
« Reply #14 on: March 20, 2015, 09:15:01 PM »

I'm thinking of molding a hugger extender for my rear mudguard. I'm hoping that should keep some of that filthy wet stuff away from the works. :)
Logged
Zero 2015 SR (+PT);
Yamaha Diversion 900
Pages: [1] 2 3