ElectricMotorcycleForum.com

  • November 23, 2017, 11:07:17 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

Electric Motorcycle Forum is live!

Pages: [1]

Author Topic: Controller Area Network (CAN) Error  (Read 1756 times)

sflorlando

  • Newbie
  • *
  • Posts: 16
    • View Profile
Controller Area Network (CAN) Error
« on: October 12, 2013, 07:05:06 AM »

Hello All,

I have a 2011 xu that was in a small fender bender.  I recently replaced a few components including a smashed display.  When I plugged in the new display it does not work.  Checking the manual with the corresponding error codes I see that the bike is reporting a Controller Area Network (CAN) Error.  Anyone have any idea what this is referring to?

thanks

Ken
Logged

firepower

  • Hero Member
  • *****
  • Posts: 669
  • Brisbane, Australia.
    • View Profile
Re: Controller Area Network (CAN) Error
« Reply #1 on: October 12, 2013, 10:35:01 AM »

Its the data bus linking bikes devices, like USB , looks like you have wiring fault.





http://www.bmwra.org/otl/canbus/
« Last Edit: October 13, 2013, 06:09:58 PM by firepower »
Logged
Suzuki SV650S 2002

sflorlando

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Controller Area Network (CAN) Error
« Reply #2 on: October 12, 2013, 08:34:00 PM »

thanks firepower, I will check the wiring.
Logged

BSDThw

  • Hero Member
  • *****
  • Posts: 647
    • View Profile
Re: Controller Area Network (CAN) Error
« Reply #3 on: October 13, 2013, 12:49:07 PM »

Did you terminated your CAN correctly?

Running my Sevcon on the "desk" I need to use a 120Ohm otherwise the system will not talk to my programmer!
« Last Edit: October 13, 2013, 12:51:51 PM by BSDThw »
Logged
Air Drag Sucks - 2012 Zero DS ZF9 - 2013 Zero FX ZF5.7

sflorlando

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Controller Area Network (CAN) Error
« Reply #4 on: October 14, 2013, 06:25:49 PM »

Thanks for everyone's help.

I checked the fuses and all wires.  I was able to get the display working when replacing one of the 58v 10 amp fuses that must have fell out. 
 
The fault may still be there, will need to doublecheck the wiring again when I get home.

This forum is great!

Ken
Logged

protomech

  • Hero Member
  • *****
  • Posts: 1974
    • View Profile
    • ProtoBlog
Re: Controller Area Network (CAN) Error
« Reply #5 on: October 14, 2013, 06:37:19 PM »

It's a nice feeling when sanity prevails!
Logged
1999 Honda VFR800i | 2014 Zero SR
Check out who's near you on frodus's EV owner map!
http://protomech.wordpress.com/

Justin Andrews

  • Hero Member
  • *****
  • Posts: 988
    • View Profile
Re: Controller Area Network (CAN) Error
« Reply #6 on: October 14, 2013, 06:59:19 PM »

I'm glad it looks like a simple fix.  :)
Logged
Zero 2015 SR (+PT);
Yamaha Diversion 900

sflorlando

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Controller Area Network (CAN) Error
« Reply #7 on: October 14, 2013, 11:19:54 PM »

Yes totally.

I do have a question about the digital display and unfortunately dont have a manual and searching hasnt come up with the answer.  How do I change it to MPH instead of KPH?  Also when I turn it on it flashes K2 for a few seconds and then changes.  Do I need to worry about that?

thanks

Ken
Logged

protomech

  • Hero Member
  • *****
  • Posts: 1974
    • View Profile
    • ProtoBlog
Re: Controller Area Network (CAN) Error
« Reply #8 on: October 14, 2013, 11:23:28 PM »

On the S displays (another koso device) there is a button (Adjust, I think?) that will switch from mph to kph. Not sure about the XU.

My display flashes what is probably a firmware version immediately when it turns on, before it goes through its init routine.
Logged
1999 Honda VFR800i | 2014 Zero SR
Check out who's near you on frodus's EV owner map!
http://protomech.wordpress.com/

spalardy

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Controller Area Network (CAN) Error
« Reply #9 on: May 10, 2017, 08:40:19 PM »

Hi, just to report that I had the same problem yesterday (CAN Bus Error) with a Zero Moto Type S (2013) when the temperature was minus 3 celsisus over the night. I try to use my moto the next morning and I had CAN Bus Error. Was not able to start and not able to charge the moto. The read light indicator was flashing 2  times and 3 times just after. The problem was auto fixed in the afternoon when the temperature was 6 celsius.
Logged
Pages: [1]