ElectricMotorcycleForum.com

Makes And Models => Zero Motorcycles Forum | 2013+ => Topic started by: MadwitTY on June 15, 2017, 06:29:26 PM

Title: 2014 SR has lurching power/torque delivery with throttle
Post by: MadwitTY on June 15, 2017, 06:29:26 PM
Hey guys.
Been having and issue the last view days that has me perplexed.
In both Custom and Sport modes, the power delivery‚Äč when twisting the throttle seems to cut in and out rapidly.
It causes a bucking feeling like your car when you have water in your gas or carburator issues. I've observed that, even when at a constant speed, say 50mph, the level indicators for both power and torque add and then subtract s bar every second or so, even with my hand maintaining the same throttle position.
This bucking issue does not seem to happen in Eco mode.

I'm hoping it's not a throttle issue. Could it be the BMS or Controller?
I'll try and download the logs asap (at work now).

Thanks!
Title: Re: 2014 SR has lurching power/torque delivery with throttle
Post by: Fred on June 15, 2017, 06:59:11 PM
I think a similar issue in the past turned out to be the brake level rattling enough to trigger the brake light and regen braking.
Title: Re: 2014 SR has lurching power/torque delivery with throttle
Post by: togo on June 15, 2017, 08:54:49 PM
I think a similar issue in the past turned out to be the brake level rattling enough to trigger the brake light and regen braking.

Check the calibration on the brake light switches. I think there's one for the foot brake and one on the hand brake. Make sure there's a little movement before the brake light activates.